Setting Up UT2004

General discussion relating to BosaikFrag goes here.
Post Reply
notipa
Posts: 80
Joined: Wed Jun 24, 2015 11:18 pm

Setting Up UT2004

Post by notipa » Fri Sep 30, 2016 11:46 am

Before Installing
If you purchased your copy from GOG, you may find that you are banned on almost every populated server. This is because GOG does not provide a unique CD key by default. You will need to request a unique CD key from GOG Support (they have an option for "Request Multiplayer Key"). After one to two days, you will receive a unique key.

UT2004, UAC, and Permissions
Windows users, be sure to install UT2004 to a directory outside of Program Files (or Program Files (x86)) to allow the game to be able to write to its config files. Alternatively, you can right-click the installation folder, select Properties, go to the Security permissions tab, click the Edit button, find the Users group, and tick the "Full Control" checkbox under the Allow column.

Patching to v3369
Windows Vista and newer users, use the normal v3369 patch. The v3372 patch should not be used unless you have a Logitech G15 as it is written specifically for that keyboard.

Linux users, use the v3369.2 patch. You will probably need to install libstdc++5 via whatever package manager your distro uses.
If you have not done so already, create a cdkey file (no extension) in the System/ directory, and type your CD key in it. The CD key should be in the following format:

Code: Select all

AAAAA-BBBBB-CCCCC-DDDDD
UT2004 and Windows 10
Windows 10 does not provide support for DirectX 8 by default. This causes the game to crash whenever it goes fullscreen. You will need to install it from here for UT2004 to function properly.

Uncapping Framerate
By default, UT2004 cannot display frames faster than either 85 or 90 FPS, depending on whether HPET is enabled. To fix this (AFTER the first execution of the game, to get INI files created), perform the following changes:
  • In User.ini, change [Engine.Player] ConfiguredInternetSpeed to 20000
  • In UT2004.ini, change [Engine.LevelInfo] MaxClientFrameRate to (at least) 160; I use 200
Higher Framerates in Recorded Demos
UT2004 displays recorded demos with a framerate of 4/3rds the tickrate of the recorded demo. The default tickrate is very low (20 or 35) to keep files small, but the files produced are painful to watch.
  • In UT2004.ini, change [Engine.DemoRecDriver] NetServerMaxTickRate to at least 50
  • In UT2004.ini, change [Engine.DemoRecDriver] LanServerMaxTickRate to at least 50

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest